News from the Web

Google Chrome BLOCKED on some PCs next month but you probably don’t need to panic

Google Chrome will stop working on some PCs next month. The release of Chrome 89 in March will bring with it some changes to the minimum requirements to access the market leading browser. And if your machine is fitted with a processor that is long in the tooth then you may not be able to access Chrome anymore.

As reported by MSPoweruser, a new policy document from the Chromium team has revealed that support is being dropped for certain chipsets.

Following the release of Chrome 89 in the stable channel on March 2, machines fitted with any x86 CPUs that does not have a minimum of SSE3 support won’t be able to run the browser.

Practically speaking, this change would affect pre-Intel Core 2 Duo processors such as the Intel Atom and Celeron M processors.

Most processors that have been released since 2005 support SSE3, so you’d have to be running a PC older than 15 years to be affected by this change.

Chrome will soon start posting a warning about this change in Chrome 87.

After the release of Chrome 89 anyone that uses a machine with a highlighted chipset won’t be able to use the browser installer.

And the browser itself will simply crash when attempting to run Chrome on affected machines that already have the software installed.

It’s believed only Windows machines will be affected by this change, and a very small proportion of users for that matter too.

Android, ChromeOS and Mac devices won’t be impacted.

In other Chrome news, users of the browser were recently put on alert about a popular extension.

The Great Suspender was a handy tool previously found on the Chrome Web Store aimed at people who typically have plenty of tabs open.

The extension would automatically suspend any tabs that users hadn’t looked at for a little while.

However, as highlighted in a post on GitHub, the extension could have been infected with malware.

The GitHub post said: “The old maintainer appears to have sold the extension to parties unknown, who have malicious intent to exploit the users of this extension in advertising fraud, tracking, and more. In v7.1.8 of the extension (published to the web store but NOT to GitHub), arbitrary code was executed from a remote server, which appeared to be used to commit a variety of tracking and fraud actions. After Microsoft removed it from Edge for malware, v7.1.9 was created without this code: that has been the code running since November, and it does not appear to load the compromised script. The malicious maintainer remains in control, however, and can introduce an update at any time. Well, they could until Google nuked the extension from their store.”

The Great Suspender has since been removed from the Chrome Web Store.

This extension alert isn’t the only Chrome warning users have received recently. Google had to push out an emergency update last week to address a vulnerability that hackers were exploiting.

SOURCE

 

Comments are closed.